Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sysprep - ohne Benutzer anlegen

Frage Microsoft Windows Tools

Mitglied: xfiles

xfiles (Level 1) - Jetzt verbinden

28.11.2013 um 14:10 Uhr, 9432 Aufrufe, 12 Kommentare, 6 Danke

Hallo zusammen,

ist wahrscheinlich nur eine Kleinigkeit aber ich komme einfach nicht dahinter.
Ich versuche den Sysprep Befehl so abzusetzen, dass ich zwar die
Willkommensseite bekomme (d.h. wo ich Computername, Username, Uhrzeit, Zeitzone etc.. einstellen kann)
jedoch möchte ich keinen neuen Benutzer anlegen. So muss ich diesen
nach der Anmeldung als Admin wieder löschen. Umständlich

sysprep /audit --> brachte nicht den gewünschten Erfolg. Start im Audit Modus und ohne Willkommensseite...

sysprep /generalize /oobe /shutdown /unattend --> evtl. so?

http://technet.microsoft.com/de-de/library/cc721973%28v=ws.10%29.aspx

Auf der Seite von MS steht leider nichts explizit dazu, wie man Vorgänge beim Start nach
dem Sysprep umgeht.

Hoffe ihr könnt mir kurz auf die Sprünge helfen.


Danke!!!!

xfiles
Mitglied: mononoke
28.11.2013, aktualisiert um 15:11 Uhr
Zitat von xfiles:
So muss ich diesen nach der Anmeldung als Admin wieder löschen. Umständlich


Hey,

Mit welchen Admin willst du dich denn anmelden?

Lokalen Admin kannst du erst nach der Grundinstallation aktivieren und in der Domäne wird der Rechner auch nicht von alleine sein.

Vielleicht habe ich deine Frage auch nur falsch verstanden? :D

gruß
Bitte warten ..
Mitglied: Xaero1982
28.11.2013 um 15:19 Uhr
Moin,

erst mal wovon reden wir?

XP? Win7?

Um das zu machen brauchst du eine entsprechende Konfigurationsdatei. Bei XP die sysprep.inf bei 7 eine xml mit entsprechenden Einstellungen.

Das hat erst mal mit dem Absetzen des Befehls nichts zu tun.

Dennoch die Frage die schon monoke stellte: Wie willst du dich als Admin anmelden? Bei w7 z.b. ist der aus.

Gruß
Bitte warten ..
Mitglied: xfiles
28.11.2013 um 17:56 Uhr
Hallo Ihr Beiden ;)

Im Image ist bereits ein Admin Account erstellt. Das Problem ist aber nicht der Admin Account.
Ich rede nicht von dem Administrator. Ich habe mir bereits einen 2. Admistrator Account erstellt --> Admin
Der ist auch nach dem Sysprep noch da. Darum geht es aber gar nicht. Jedoch werde ich von Windows gezwungen nach dem
sysprep und Reboot einen User Account anzulegen. Das möchte ich unterbinden, da schon ein User Account
in meinem Image existiert. Es handelt sich um Windows 7 Professional.

Vielen Dank für Eure schnelle Unterstützung und sorry für meine schlechte Erklärung.
Bitte warten ..
Mitglied: departure69
28.11.2013 um 18:32 Uhr
Hallo.

Ich glaube, Du hast die Unattended.xml nicht richtig erstellt oder angepaßt. Im WAIK (und darin einem Tool, dessen Namen ich jetzt gerade nicht weiß) lade ich immer eine *.wim aus einer neutralen W7Pro64SP1-DVD, die Grundlage für mein Master-Image ist. Dann erstelle ich darin die Unattended.xml. Einzige Option, die ich dabei wähle, ist, daß ich den im Aufzeichnungsmodus angelegten User MIT IM zu capturenden Image (per imagex) haben will. Nach dem Capturing setze ich die DVD bzw. ISO mit der neuen *.wim-Datei wieder zusammen, mache sie bootfähig und installiere testweise in einer virtuellen Maschine, um zu sehen, ob die neue DVD (oder die neue ISO) funktioniert. Hab' ich die Unattended.xml vorher korrekt erstellt, melde ich mich bei diesem Test mit dem User an, den ich im aufgezeichneten Master-Image angelegt hatte - ich muß keinen neuen User anlegen (den man in der Tat später löschen müßte). Sogar das Profil des im Master-Image angelegten Users ist dann da, so wie ich es erstellt hatte (Aussehen des Desktop usw.), und dieses Profil ist dann sogar das Standardprofil für alle User, die sich jemals auf dem Rechner anmelden werden.

Meines Erachtens mußt Du Dir lange, lange vor Deiner Masterinstallation im WAIK erstmal eine passende Antwortdatei erstellen, die Du später dem Sysprep-Befehl mitgibst.

Hier steht es sehr viel fundierter, ist zwar für Vista, klingt aber ganz danach, wie ich es immer mache (autologon und copyprofile mitgeben):

http://technet.microsoft.com/de-de/library/cc766343(v=ws.10).aspx


Grüße

von

departure
Bitte warten ..
Mitglied: cardisch
29.11.2013 um 09:33 Uhr
Moin,

ich habe mich mit dieser "Problematik" abgefunden, dass da Win7 anders reagiert, als XP.
Ich mache meine Sysprep-Image immer so:
sysprep /generalize /oobe /shutdown und lebe mit diesem "Fehler"
Und wenn du nicht gerade dutzende oder gar hunderte Rechner im Monat zu fertigen hast, dann finde ich (persönlich) WAIK zu überdimensioniert.

Gruß

Carsten
Bitte warten ..
Mitglied: xfiles
29.11.2013 um 10:28 Uhr
Hier ist meine xml.
Wo genau, bzw. wie definiere ich, dass der Benutzeraccount nicht angelegt werden soll?
Danke schon mal
<SkipAddUser>true</SkipAddUser> --> unter generalize ??


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="generalize">
<component name="Microsoft-Windows-Security-SPP" processorArchitecture="x64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SkipRearm>1</SkipRearm>
</component>
<component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="x64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SkipAutoActivation>true</SkipAutoActivation>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<ShowWindowsLive>false</ShowWindowsLive>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="x64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<InputLocale>de-DE</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UserLocale>de-DE</UserLocale>
<UILanguageFallback>en-US</UILanguageFallback>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<UserAccounts>
<AdministratorPassword>
<Value>bgBvAHQAZQBiAG8AbwBrAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>
<PlainText>false</PlainText>
</AdministratorPassword>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value>bgBvAHQAZQBiAG8AbwBrAFAAYQBzAHMAdwBvAHIAZAA=</Value>
<PlainText>false</PlainText>
</Password>
<Description>Local Administrator</Description>
<Name>admin</Name>
<Group>Administrators</Group>
<DisplayName>admin</DisplayName>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
</OOBE>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:c:/windows-imaging/wim-windows%207%20professional%20with%20service%20pack%201%20(x64)/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Bitte warten ..
Mitglied: Xaero1982
LÖSUNG 29.11.2013, aktualisiert 03.01.2014
01.
<?xml version="1.0" encoding="utf-8"?> 
02.
<unattend xmlns="urn:schemas-microsoft-com:unattend"> 
03.
    <settings pass="oobeSystem"> 
04.
        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
05.
            <InputLocale>de-DE</InputLocale> 
06.
            <UILanguage>de-DE</UILanguage> 
07.
            <UserLocale>de-DE</UserLocale> 
08.
            <SystemLocale>de-DE</SystemLocale> 
09.
        </component> 
10.
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
11.
            <OOBE> 
12.
                <HideEULAPage>true</HideEULAPage> 
13.
                <NetworkLocation>Work</NetworkLocation> 
14.
                <ProtectYourPC>1</ProtectYourPC> 
15.
                <SkipUserOOBE>true</SkipUserOOBE> 
16.
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE> 
17.
            </OOBE> 
18.
            <UserAccounts> 
19.
                <AdministratorPassword> 
20.
                    <Value>xxxxx</Value> 
21.
                    <PlainText>false</PlainText> 
22.
                </AdministratorPassword> 
23.
                <LocalAccounts> 
24.
                    <LocalAccount wcm:action="add"> 
25.
                        <Password> 
26.
                            <Value>xxxxx</Value> 
27.
                            <PlainText>false</PlainText> 
28.
                        </Password> 
29.
                        <DisplayName>Administrator</DisplayName> 
30.
                        <Group>Administrators</Group> 
31.
                        <Name>Administrator</Name> 
32.
                        <Description>local Admin</Description> 
33.
                    </LocalAccount> 
34.
                </LocalAccounts> 
35.
            </UserAccounts> 
36.
            <RegisteredOrganization>xxxxx</RegisteredOrganization> 
37.
            <RegisteredOwner>xxxxx</RegisteredOwner> 
38.
            <Themes> 
39.
                <DefaultThemesOff>false</DefaultThemesOff> 
40.
            </Themes> 
41.
            <TimeZone>W. Europe Standard Time</TimeZone> 
42.
        </component> 
43.
    </settings> 
44.
    <settings pass="generalize"> 
45.
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
46.
            <SkipRearm>1</SkipRearm> 
47.
        </component> 
48.
    </settings> 
49.
    <cpi:offlineImage cpi:source="catalog://idefix/reminst/images/windows 7 install/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> 
50.
</unattend> 
51.
 
Versuchs mal damit...

Gruß
Bitte warten ..
Mitglied: departure69
29.11.2013, aktualisiert um 12:42 Uhr
@cardisch:

Hallo.


Zitat von cardisch:

Moin,

ich habe mich mit dieser "Problematik" abgefunden, dass da Win7 anders reagiert, als XP.

Ich halte es nicht für eine Problematik, sondern aus Sicherheitsgründen für sinnvoll, daß der lokale Admin per Default deaktiviert ist und man standardmäßig zunächst einen User anlegen muß, so ist erst mal sicher, daß niemand mit administrativen Rechten in den Rechner "hineinkommt", der ihn nicht gerade selber installiert hat oder als erster in Betrieb nimmt.

Ich mache meine Sysprep-Image immer so:
sysprep /generalize /oobe /shutdown und lebe mit diesem "Fehler"

Wie gesagt, für einen Fehler halte ich das nicht. Und im Übrigen ist der "Fehler" ja durchaus behebbar, wenn man die richtige Antwortdatei (bzw. darin die richtigen Einstellungen/Befehle) nimmt, die dann die Defaulteinstellungen wie gewünscht oder benötigt abändert.

Und wenn du nicht gerade dutzende oder gar hunderte Rechner im Monat zu fertigen hast, dann finde ich (persönlich) WAIK zu
überdimensioniert.

Das einzige, was m. E. am WAIK überdimensioniert ist, ist die Downloadgröße (für W7SP und W2K8R2 sind es bspw. 1,6 Gigabyte). Ansonsten sind die Bestandteile des WAIK überaus nützlich und im Umfang ansonsten harmlos, wenn man eine Antwortdatei erstellen und einen Rechner mit ImageX abziehen will, das geht mit wenigen Mausklicks und einer Zeile Befehlscode, dafür hat man's dann so, wie es korrekt ist. Und wer nur Mausklicken will und gar keinen Befehl tippen, für den gibt's auch noch eine GUI für ImageX: http://www.autoitscript.com/site/autoit-tools/gimagex/ (ist jetzt schon für W8.1, gibt aber auch ältere Fassungen davon, die für Vista oder 7 geeignet sind).


Gruß

Carsten

Viele Grüße
Bitte warten ..
Mitglied: xfiles
29.11.2013 um 13:17 Uhr
Danke Xaero1982,

ich lege grade eine Test VM an und teste es gleich mal ;)

Bitte warten ..
Mitglied: Xaero1982
29.11.2013 um 13:38 Uhr
Viel Erfolg, aber ich übernehme keine Garantie ... ungetestet

Habe meine nur zurecht gestutzt und die läuft vollautomatisch durch inkl. Domänenbeitritt etc.

Gruß
Bitte warten ..
Mitglied: xfiles
29.11.2013 um 15:03 Uhr
Vielen, vielen lieben Dank. Das hat super funktioniert
Du bist der BESTE !!!!

Gruß

xfiles




Fall geschlossen!
Bitte warten ..
Mitglied: Xaero1982
29.11.2013, aktualisiert um 15:24 Uhr
Freut mich, dass es geklappt hat.

Viel Spaß damit

Gruß
PS: Übrigens konnte ich deine XML nicht im WAIK laden. Vielleicht hat deine auch einfach nur nen Schuss gehabt?!
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Benutzer anlegen mit Set-ADAccountExpiration
gelöst Frage von PeterzBatch & Shell3 Kommentare

Hallo, ich habe mir ein Script mit Powershell (z.T. mit Inputboxen) zusammengebaut, mit dem ich AD-Benutzer anlegen kann. Nun ...

Windows 7
SYSPREP Windows 7 ohne neuen Nutzer anlegen zu müssen
Frage von domestoneWindows 74 Kommentare

Guten Tag, Ich bin gerade beim Installieren von 200 identischen Computern, und müsste ein Sysprep machen damit ich dieses ...

Windows Installation
Unattended.xml : Benutzer anlegen : Benutzerpfad definieren
Frage von StfnCstrWindows Installation1 Kommentar

Hallo Zusammen, Ich habe ein WindowsServer2012R2 image und eine Unattended.xml erstellt. Damit lasse ich mir via PS Hyper-V VMs ...

Windows Tools
Sysprep Auditmode: User anlegen via lusrmgr. VS Unattend.xml
Frage von dankon7gooWindows Tools1 Kommentar

Hallo, ich weiß meine Frage mag sonderbar anmuten. Aber hat jemand vielleicht hier eine Erfahrung Wir nutzen für unsere ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 41 MinutenViren und Trojaner

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 4 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell8 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...