Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows und Linux in VMware ohne Router erhalten keine IP Adressen

Frage Netzwerke Router & Routing

Mitglied: goldfisch1980

goldfisch1980 (Level 1) - Jetzt verbinden

14.08.2008, aktualisiert 10:03 Uhr, 8753 Aufrufe, 7 Kommentare

gegen ist folgende Netzwerkarchitektur (grob):
1x WINDOWS VISTA (erhält per DHCP die Netzwerkadresse)
1x DEBIAN Linux in einer VMware (hat eine fest eingetragene IP Adresse, das Netzwerk der VMware ist auf bridged einstellt)
1x ROUTER (mit DHCP Server)

Das Problem ist folgendes:

Ich habe in meinem Linux System (vmware) mittels Samba einige Netzwerklaufwerke zum Einbinden unter Windows bereit gestellt. Soweit funktioniert das auch wunderbar und es soll auch so bleiben.

Allerdings habe ich das Problem, dass die Kommunikation zwischen VISTA und dem Linux nur dann funktioniert, wenn auch eine Verbindung zu meinem Router (oder ein anderer entsprechend konfigurierter Router mit dem Adressbereich 192.168.2.x) hergestellt ist. Sobald ich mich in anderen Netzwerken befinde, geht gar nix mehr (z.B. wenn ich mich unterwegs mittels dem Vodafone MobileConnect einwähle oder natürlich gar keine Netzwerkverbindung besteht). In diesem Fall funktioniert weder der Zugriff auf die Netzlaufwerke, noch der Webserver (Apache) läuft etc.. Ein Ping aus dem Linux funktioniert auch nur dann, wenn ich mich in meinem 192.168.2.x Netzwerk befinde. Habe ich eine Verbindung mit dem Vodafone UMTS Stick hergestellt, kommt eine ping anfrage weder an der vmware an noch aus dieser "raus"...

Jetzt meine Frage:
1) Wie kann ich es ermöglich, dass ich von dem HOST System (VISTA) die vmware in jedem Netzwerkzustand (d.h. keine netzwerkverbindung besteht, verbindung mit 192.168.2.x oder 10.0.0.x oder einem ganz anderen Netzwerk) ansprechen kann? Bisher dachte ich genügt die vergabe einer festen adresse für das Linux aus, aber dem ist nicht so! Und unter VISTA ist das für mich auch nicht gerade erwünscht eine feste IP einzutragen. Dafür wechsle ich zu oft die Netze und soweit ich weiss geht auch nicht wirklich (media sensing etc.)...
2) selbst wenn eine Verbindung besteht (z.B. mit dem Vodafone MobileConnect), wie kann ich es schaffen, dass ich aus der VMware raus in das andere Netzwerk komme... Der Adressbereich ist ja nicht identisch! Das Vodafone Netz ist 89.x.x.x und das Linux (vmware) fix auf 192.168.2.50. Kann man das vielleicht über das setzen von routen lösen? route add ...... ? Wenn Ja, bitte an dieser Stelle konkret werden, weil ich mich mit dem Befehl und deren Sinn der einzelnen Parameter überhaupt nicht so klar komme. Bitte daher um Hilfe.

Und ich sags vorab: ich kenn mich zwar bisschen mit Netzwerken aus, aber bin alles andere als ein Fachmann, also bitte verständlich bleiben! Danke.



Besten Dank im voraus,
Phil


Kleines Diagramm:

fab98dd9bcdb4864091fe52134c0dc72-diagramm - Klicke auf das Bild, um es zu vergrößern
Mitglied: floetenfranz
14.08.2008 um 08:20 Uhr
moin goldfisch1980

habe hier ein ähnliches Konstrukt auf meinem Notebook.
Host: XP
Gast: XP

im Gast läuft ein Mailserver/Outlook 2003.
Ich habe den Gast auf NAT umgestellt.
Damit kann ich; in welchem Netz ich mich auch immer befinde,
ohne am Gast etwas umkonfigurieren zu müssen, aufs Inet zugreifen.
Ebenso ist der Zugriff in den Gast jederzeit möglich.

check das mal

salut
Bitte warten ..
Mitglied: harald21
14.08.2008 um 08:21 Uhr
Hallo,

deine Beschreibung ist ein bischen konfus - hast du evtl ein Netzwerkdiagramm?

Mit freundlichen Grüßen
Harald
Bitte warten ..
Mitglied: floetenfranz
14.08.2008 um 08:30 Uhr
am frühen Morgen nen Diagramm.. :o)
hab ich natürlich nicht.

Wir gehens x gemeinsam durch.

1. Stelle deine VM (LINUX) von "Bridged" auf "NAT"
2. hol dir mit ipconfig -release / renew (oder wie hies das bei LINUX) ne neue IP.
3. ping deine VM mal von HOST (VISTA) aus an, klappts?
4. versuche jetzt x auf shares in der VM zuzugreifen
5. berichte....

salut
Bitte warten ..
Mitglied: AndreasHoster
14.08.2008 um 09:28 Uhr
Wie die anderen geschrieben haben ist NAT hier das Zauberwort.
Und zur Ursache Deines Problems:
Windows legt die Ethernetschnittstelle schlafend, wenn keine Gegenstelle dran ist. Dadurch tut bridged nicht mehr, da die Ethernetschnitstelle auf die gebridget werden soll nicht mehr aktiv ist.
Bitte warten ..
Mitglied: goldfisch1980
14.08.2008 um 09:47 Uhr
Ich glaube das mit dem Diagramm war für mich gedacht? *gg*

Ich habe das nun versucht mit Umstellung auf NAT. Sobald ich das Umstelle, geht aber gar nix mehr (ich kann weder das Linux in der vmware anpingen noch bekomme ich eine antwort aus der vmware vom vista (Gastsystem) zurück..
Ne neue IP Adresse bekomme ich normal dadurch, dass ich den networking dienst neu starte:

/etc/init.d/networking restart

Aber das half nicht.. Im übrigen ist ja eine Statische IP Adresse eingetragen... Muss ich das ändern?



Grüsse
Phil


PS: Ich habe Ein Diagramm am frühen morgen erstellt (siehe oben)
Bitte warten ..
Mitglied: goldfisch1980
14.08.2008 um 09:51 Uhr
Okay.. ein "Diagramm" ist dabei.. Wobei da eigentlich nix spektakuläres dabei ist.. Ein Gastsystem VISTA mit einer VMware (virtuelle Umgebung) wo ein Linux drin läuft.
Die Netzwerkanbindung erfolgt in VISTA auf verschiedene Weisen: LAN, WLAN, UMTS und kann mit Router 1, Router 2, einem anderen oder gar keinem verbunden sein (=> verschiedene Adressräume werden hier in Windows verwendet.)

gruss
Phil
Bitte warten ..
Mitglied: floetenfranz
14.08.2008 um 10:02 Uhr
OK,

stelle testweise deine VM mal auf DHCP um.
Hintergrund: das NAT Device ist nix weiter als ein virtueller Router. Auf diesem ist bereits ein DHCP Server integriert. Dieser verteilt per DHCP bis zu 128 IP-Adressen. Damit kriegst du also alle VM's, die du per NAT anbindest sofort ins Internet.
Übrigens: Wenn ich in meinem Firmennetz bin greift meine VM dann darüber auf meinen DC zu......

salut
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
gelöst Windows Server - IP Adressen (10)

Frage von Richard97 zum Thema Windows Server ...

Monitoring
System Monitoring für Windows, Linux (3)

Frage von manuelw zum Thema Monitoring ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...