Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

iPhone via Active Sync an Exchange Server anbinden

Anleitung Microsoft Exchange Server

Mitglied: Seardan

Seardan (Level 1) - Jetzt verbinden

18.07.2009, aktualisiert 18.10.2012, 102722 Aufrufe, 55 Kommentare, 9 Danke

Mittlerweile hat es auch im Geschäftsleben überall Einzug gehalten ... das iPhone. Und das erste was die stolzen iPhone Nutzer wollen ... Mails vom Exchange Account. Diese Anleitung soll ein wenig dabei helfen.

Hier eine Anleitung, wie ich es gemacht habe und es auf einem SBS2003 R2 mit Exchange 2003 SP2 funktioniert:

Im IIS:
- [Servername]->Websites->Standardwebsite
- Microsoft-Server-ActiveSync, OMA ,exchange-oma folgende Änderungen vornehmen:
- Microsoft-Server-ActiveSync:
-Virtuelles Verzeichnis: Besuche protokollieren, ressource indizieren
Ausführungsberechtigungen: skripts und ausführbare Dateien
Anwendungspool: ExchangeApplicationPool
-Verzeichnissicherheit: Sichere Kommunkikation->bearbeiten->SSL auschalten

- OMA:
-Virtuelles Verzeichnis: Lesen, Besuche protokollieren, ressource indizieren
Ausführungsberechtigungen: nur skripts
Anwendungspool: ExchangeMobileBrowseApplication
-Verzeichnissicherheit: Sichere Kommunkikation->bearbeiten->SSL auschalten

- exchange-oma:
-Virtuelles Verzeichnis: Skriptzugriff, Lesen, Schreiben, Verzeichnis durchsuchen, Besuche protokollieren, ressource indizieren
Ausführungsberechtigungen: keine
-Verzeichnissicherheit: Sichere Kommunkikation->bearbeiten->SSL auschalten

Im Exchange System-Manager:
- auf Server->[Servername]->Protokolle->HTTP->Virtueller Exchange-Server
- auf Register Einstellungen: formularbasierte Authentifikation auschalten

Im IIS:
- rechtsklick auf Server
- Alle Aufgaben->konfiguration sichern/wiederherstellen
- Sicherung der IIS-Konfig erstellen und mit OK bestätigen
- rechtsklick auf den Server -> Eigenschaften
- direktes bearbeiten der Metabasis ermöglichen
- datei im Editor öffnen: c:\WINDOWS\system32\Inetsrv\metaBase.xml
- die Zeile suchen: <IIsWebVirtualDir Location ="/LM/W3SVC/1/ROOT/Microsoft-Server-ActiveSync"
- DoDynamicCompression="TRUE" auf FALSE setzen
- DoStaticCompression="TRUE" auf FALSE setzen

Im Exchange System-Manager:
- auf Server->[Servername]->Protokolle->HTTP->Virtueller Exchange-Server
- rechtsklick auf neu->virtuelles Verzeichnis
- Name: exchDAV
- Exchange-Pfad: Postächer für SMTP-Domäne
- mit OK bestätigen bis alle Fenster zu sind

regedit öffnen:
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
- Zeichenfolge ExchangeVDir auf /exchDAV setzen

im IIS:
- auf [Servername]->Websites->Standardwebsite
- exchDAV rechtsklick auf Eigenschaften
- Register Verzeichnissicherheit auf Einschränkungen für IP-Adressen und Domänennamen
- auf zugriff verweigert stellen
- hinzufügen anklicken und die IP des Servers aufgeben
- mit OK bestätigen bis alle Fenster zu sind
-Virtuelles Verzeichnis: Besuche protokollieren, ressource indizieren
Ausführungsberechtigungen: skripts und ausführbare Dateien
Anwendungspool: ExchangeApplicationPool
-Verzeichnissicherheit: Sichere Kommunkikation->bearbeiten->SSL auschalten

in die Diensteübersicht des Servers:
- Dienst "www-Publishingdienst" neu starten

das wars für die Konfiguration des Servers.

Im iPhone müssen dann folgende Daten hinterlegt sein:
- iPhone Web Configuration Utility:
- Exchange-Daten:
-ActiveSync-Account: email-adresse
- Server: die Adresse, über die der Server per DynDns gemeldet ist (firma.dyndns.org)
- Email-Adresse ist klar
- Benutzer: [lokale Domain]\[Benutzername]
- ein vom SBS erstelltes Zertifikat reinladen

- Dieses Profil auf dem iPhone installieren

Ich rate erstmal dazu die 3G-Funktion des iPhones zu deaktivieren und dann in den Einstellungen das Exchange-Konto so zu konfigurieren, dass es nur die Emails syncronisieren soll. Wenn dies passiert, kann man auch Kalender und Kontakte hinzufügen.

So haben wir es gemacht und es hat funktioniert.
Ich hoffe, dass ich damit vielen helfen kann, die kein Geld hatten um sich 3 oder 4 Server hinzustellen. Die meisten Anleitungen sind für Frontend- und Backendserver ausgerichtet. Der SBS ist ein reiner Frontend und die Anleitungen sind meist unbrauchbar. Fakt ist, dass man eine VPN-Verbindung definitiv für einen SBS nicht braucht. Es funktioniert bei uns wunderbar auch ohne. OWA muss installiert und voll funktionsfähig sein und die Mobile Access Punkte in IIS und Exchange müssen aktiviert sein.

Ich wünsche allen Inhabern eines iPhones und eines Exchange viel Spass und hoffe, dass ich die Arbeit von 3 Tagen, die wir hatten Anderen hiermit ersparen kann.

Allen Helfern hier auch vielen Dank für die Mühe.

Gruß Andreas
55 Kommentare
Mitglied: Pjordorf
22.07.2009 um 22:37 Uhr
War bei mir etwas einfacher.

Zuerst mittels den asisstenten das OWA richtig konfiguerieren. Port 443 korrekt auf den SBS weiterleiten. Testen mittels Outlook Client von ausserhalb deines Netzes (Outlook über HTTPS). wenn das geht kann ein IPhone oder smartphone problemlos angebunden werden. Dazu ist das IPhone Web Configuartion Utility nicht vonnöten. Das IPhone nach Anleitung des IPhone Benutzerhandbuchs anbinden. Fertig

Peter
Bitte warten ..
Mitglied: Seardan
23.07.2009 um 23:24 Uhr
Hallo Peter,

tja ... wenn es immer so einfach wäre!

Das iPhone Utilitie ist aber trotz allem sehr fein. Ich kann jetzt sogar iPhone Geräte von den absoluten super Dau's anbinden. Egal wo sich diese in Europa befinden. File senden ... klick ... angebunden!!! Tolle Sache.


Andreas
Bitte warten ..
Mitglied: themoon19
04.08.2009 um 20:00 Uhr
HI Alle,
und wie schaut es mit der Einstellung am IPhone aus bzgl. Proxyeinstellung??
ich finde keinen Punkt wo ich den Proxy eingeben kann um mich dann indirekt local am Firmennetz anzumelden!

Aber ansonsten tolle Anleitung
Bitte warten ..
Mitglied: Pjordorf
05.08.2009 um 00:23 Uhr
Hallo themoon19,

Proxy, I-Phone ???

Also mein I-Phone hat nur dann die möglichkeit einen Proxy einzugeben/suchen wenn ich WLAN Netze nutze. Sonst Funkt das Teil doch über GPRS/UMTS/HSPDA usw. und daswillst du doch bestimmt nicht über DEINEN Proxy laufen lassen, oder?

Peter
Bitte warten ..
Mitglied: CeMeNt
14.08.2009 um 14:02 Uhr
Prima! Diese Anleitung gleich mal als Favorit verlinkt!

Mein Chef hat mir schon ange droht deutet, dass er jetzt auch so'n Ei-Fon haben will.
Und wir haben ebenfalls den SBS2003 im Einsatz.
Wenn es tatsächlich dazu kommen sollte, wird mir Deine Anleitung sicherlich eine große Hilfe sein!

Gruß CeMeNt
Bitte warten ..
Mitglied: bongartz
29.08.2009 um 16:10 Uhr
Danke gute Antwort. an sollte noch erwähnen das es nur mit dem Exchange 2003 R2 geht.
Bitte warten ..
Mitglied: bongartz
03.09.2009 um 11:16 Uhr
Zitat von Pjordorf:
War bei mir etwas einfacher.

Zuerst mittels den asisstenten das OWA richtig konfiguerieren. Port
443 korrekt auf den SBS weiterleiten. Testen mittels Outlook Client
von ausserhalb deines Netzes (Outlook über HTTPS). wenn das geht
kann ein IPhone oder smartphone problemlos angebunden werden. Dazu ist
das IPhone Web Configuartion Utility nicht vonnöten. Das IPhone
nach Anleitung des IPhone Benutzerhandbuchs anbinden. Fertig

Peter

Also ich bekomme diese Test nicht hin. Habe die http Einstellung bei Outlook genommen und dann meinen Dyndns Pfad eingeben. Aber der Server kann sich nicht verbinden. Ist die E-Msiladrese für den Verbindungsaufbau wichtig oder kann man diese vernachlässigen?

Wenn ich den Server per imap einriechte mit dem selben Einstellung geht es ohne Problem.

Nur wenn ich es mit https oder auf dem iphone per Exchange versuche geht leider nichts.
Bitte warten ..
Mitglied: Globetrotter
07.11.2009 um 18:45 Uhr
Hi Andreas..
subber Ding...
Hat auf Anhieb funktioniert - W2K3 - SP2 +Exchange E2K3 SP2

Danke !

Gruss Globe
Bitte warten ..
Mitglied: tuxxer
08.02.2010 um 18:28 Uhr
hat es schon jemand getestet das ganze auch per ssl-verschlüsselung zubetreiben?
Bitte warten ..
Mitglied: Globetrotter
08.02.2010 um 18:53 Uhr
Hi..

- mit selfssl aus IISRES das Zertifikat erstellen
- Zertifikat in IIS importieren und freischalten
- IIS auf ssl-connections (...oma etc.) umstellen.

Fertig

Gruss Globe...
Bitte warten ..
Mitglied: tuxxer
08.02.2010 um 19:42 Uhr
Holl Globe,

danke für deine schnelle antwort.

Meinst du etwa dies? http://www.msexchangefaq.de/tools/selfssl.htm

Wenn ja werde ich dieses gleich Morgen ausprobieren.

Danke und LG Tuxxer
Bitte warten ..
Mitglied: Globetrotter
08.02.2010 um 22:07 Uhr
Wenn Du eben verisign od. sonstiges benutzen willst, lannst Du zuerst mit SELFSSL testen und später das "richtige" Zertifikat im IIS installieren. Grundsätzlich immer die Site von Frank anschauen, da steht alles was Mann/Frau/Server/Client braucht ;)

Gruss Globe
Bitte warten ..
Mitglied: V-max1992
09.02.2010 um 11:42 Uhr
Hallo,

mit Interesse habe ich Eure Tipps und auch viele andere Anleitungen gelesen.
Ich bin alles mehrmals durchgegangen. Unsere Einstellungen stimmen, auch mit anderen Anleitungen, überein!
Hoffnungslos!!!
Das iPhone mault:
E-Mails können nicht empfangen werden. Die Verbindung mit dem Server ist fehlgeschlagen.

OWA funktioniert über das iPhone und auch über jeden externen Rechner fast ohne Probleme.
Einzig die folgende Meldung erscheint:
Das Zertifikat dieser Webseite ist ungültig....
Nach "Akzeptieren" verbindet er aber problemlos.

Unsere Struktur:

Domain/File- Server: Server 2008 R2 SP1
Exchange-Server: Server 2003 R2 SP2
eine feste IP ist vorhanden
Zertifikat ist erstellt

Lustigerweise haben wir das schon bei einem Kunden installiert und es funkionierte problemlos!
Wir haben natürlich alle Einstellungen verglichen, keine Auffälligkeiten!?
Die Unterschiede zum Kunden:
- anderer Internet Provider
- Domain/File- Server: Server 2003 Standard

Hat noch jemand eine Idee, mir sind sie leider ausgegangen!!

Im Voraus vielen Dank!

Grüße,
Oliver
Bitte warten ..
Mitglied: rzlbrnft
22.02.2010 um 17:10 Uhr
Ich hatte bei uns die gleiche Fehlermeldung.

Bei uns lag es daran, das die User für die lokale Anmeldung am Exchange gesperrt waren, die muss aber erlaubt sein, damit die Standardauthentifizierung funktioniert.
Integrierte Windows-Authentifizierung kann das Iphone nämlich nicht.

Als wir unter "Anmelden an" im AD den Exchange Server mit eingetragen haben ging es plötzlich.

Vielleicht ist es bei euch ja genauso.
Bitte warten ..
Mitglied: Nyghtwalker
22.02.2010 um 17:27 Uhr
Hi alle zusammen,

habe mich dieses Themas auch einmal angenommen und unsere firmeninternen iPhones an den Exchange angebunden. Nun stellen sich mir aber folgende Fragen zur SIcherheit:

- Da ich über eine feste IP-Adresse mit Portforwarding auf unseren SBS2003 gehe kann ja auch jedermann auf unsere interne Firmenwebsite gelangen, sobald er die IP weiss. Kann man das nicht umgehen?

- Zum Thema SSL / Zertifikate: Auch eine Frage im Zusammenhang mit der festen IP, sobald jemand über diese (z.B. mit nem stinknormalen Browser) unseren SBS ansteuert bekommt er ja das Zertifikat angezeigt und kann dieses verwenden, ist das nicht ein enormes Risiko?

Wir haben zwar SSL Verschlüsselung aktiviert, aber mir bereitet es echt Kopfzerbrechen, dass unser SBS eigentlich so quasi angreifbar geworden ist.

Was meint Ihr zu diesem Thema?
Bitte warten ..
Mitglied: V-max1992
23.02.2010 um 08:46 Uhr
Hallo rzlbrnft,

vielen Dank!!

Das werden wir gleich mal ausprobieren.

Gruß,
Oliver
Bitte warten ..
Mitglied: rzlbrnft
23.02.2010 um 12:38 Uhr
Welche Ports gibst du denn frei?

Bei uns ist das z.B. nur der 443 für die Iphones, über den kommst du nicht an die Firmenwebsite ran.
Bitte warten ..
Mitglied: Nyghtwalker
23.02.2010 um 13:24 Uhr
Bei mir ebenfalls nur Port 443.
Habe den Fehler gefunden, war in unserem WLAN, klar dass ich dann auf unser Companyweb komme. "Gnampf", wie Bernd sagen würde.
Bitte warten ..
Mitglied: San-Telmo
04.05.2010 um 12:13 Uhr
Hallo zusammen,

ich bekomme das leider nicht hin, vielleicht hat noch jemand eine Idee die mir weiterhelfen könnte:

Habe einen Windows SBS2003 R2 SP 2 mit Exchange 2003 SP2.
Die Anleitung habe ich Schritt für Schritt verfolgt. Bin mir aber nicht hundertprozentig sicher ob ich das mit dem Zertifikatserver alles richtig gemacht habe.

Da er nicht installiert war habe ich die Zertifikat Dienst unter Windows Komponenten hinzufügen installiert. Dann habe ich domain/certsrv aufgerufen und bin auf Zertifikat anfordern gegangen --> Benutzer Zertifikat --> Zertifikat installieren.

Nun habe ich mir das iPhone Web Configuration Utiliy installiert und damit die Exchange Daten eingetragen, das zuvor heruntergeladene und installierte Zertifikat gewählt und anschliessend das Profil zum iPhone hochgeladen.
Nun bekomme ich die Meldung, dass das Zertifikat nicht verifiziert werden kann --> Dies akzeptiere ich
Nächste Meldung: Es gab einen Fehler beim Versuch den Server zu kontaktieren. Wenn das Konto nach Beendigung der Installation nicht verifiziert werden kann werden keinerlei Daten heruntergeladen.

Ich kann mich ohne Probleme über eine Website https://domain/exchange mit OWA verbinden, das klappt ohne Probleme.

Bitte um Hilfe, ich hoffe ihr habt noch einen Tipp für mich.

Danke im voraus
Bitte warten ..
Mitglied: rzlbrnft
04.05.2010 um 12:25 Uhr
IPhone nutzt nicht die OWA Seite sondern https://domain/Microsoft-Server-ActiveSync.
Wenn du diese Seite über den Internet Explorer aufrufst, sollte ein HTTP-Error 501 Nicht implementiert bzw. 505 Version wird nicht unterstützt Fehler kommen, das heißt das Active Sync funktioniert.
Bitte warten ..
Mitglied: San-Telmo
04.05.2010 um 16:29 Uhr
Ok, ich habe das versucht und wenn ich die externe IP-Adresse anspreche dann bekomme ich die Fehlermeldung, dass ich nicht authorisiert bin die Seite anzuzeigen. Müsste ja nur eine Einstellung im IIS sein.

Wenn ich die interne Adresse https://192.168.16.2/Microsoft-Server-ActiveSync) anspreche, dann bekomme ich die von dir geschilderte Seite HTTP 501/HTTP 505.

Das müsste dann bedeuten, dass Active-Sync aktiviert ist, richtig?
Bitte warten ..
Mitglied: 3faltigkeit
08.07.2010 um 13:37 Uhr
Hallo,

ich ahbe einen Kunden der sein IPhone ebenfalls von extern (umts) an seinen exchange server angebunden haben möchte.
Was mir gerade nicht ganz klar ist muss ich das Iphone per activeSync anbindne oder kann ich das auch irgendwie anders ganz einfach über die OWA Adresse bewerkstelligen?
also https://dyndns/exchange:443. Ich selbst habe noch nie ein Iphone in der Hand gehabt und deswegen würd emich interessieren welche möglichkeiten es gibt.

Mit besten Grüßen
Bitte warten ..
Mitglied: sandorfi
22.09.2010 um 17:33 Uhr
Hallo zusammen,

ich habe ebenfalls eine Umgebung Exchange 2003 per iPhone anzubinden.
Folgendes Szenario / Fehlerbild bei mir:

Exchange ist über Port 443 von Extern erreichbar. Einstellungen sind im iPhone eingegeben und erfolgreich getestet. (Externe IP als Serveradresse)
Sende ich eine neue E-Mail an dieses Userpostfach wird die mail jedoch erst dann auf dem iPhone angezeigt / synchronisiert, wenn ich diese auch per lokalen Outook Client augerufen habe. Dies ist natürlich nicht Sinn der Sache, denn wenn der User Mobil unterwegs ist, ist ja eben kein lokales Outlook irgendwo offen.
Hat jemand eine Idee dazu?
Danke und Grüße
Simon
Bitte warten ..
Mitglied: RG2525
12.11.2010 um 12:26 Uhr
Was ist hier der Fehler?

iphone/exchange funktioniert über WLAN im Büro
iphone/exchange funktioniert über internet nicht
Port 443 richtung exchange server ist offen > OWA funktioniert mit iPhone auch
als host ist die extern erreichbare hostname vom server eingetragen. OWA funktioniert mit diesem Hostnamen von iPhone aus auch.

Es handelt sich um ein SBS 2003
Wenn das Ganze mit WLAN funktioniert sind dann Server und iPhone richtig konfiguriert
Wenn OWA von iphone aus auch funktioniert ist dann der Firewall auch richtig konfiguriert.

Was kann hier falsch konfiguriert sein?

Danke
Mike
Bitte warten ..
Mitglied: Nyghtwalker
12.11.2010, aktualisiert 18.10.2012
Bitte warten ..
Mitglied: RG2525
12.11.2010 um 22:38 Uhr
Hi,
das war dieser wizzard in sbs, wo man die acive sync aktivieren muss.
ist erledigt.
danke
Mike
Bitte warten ..
Mitglied: hollow84
06.03.2011 um 18:36 Uhr
hab 2 problemchen

1. - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
- Zeichenfolge ExchangeVDir auf /exchDAV setzen

existiert bei mir gar nicht?!

Emails empfangen und senden per iphone geht aber!

aber wie bekomm ich einen im outlook für alle freigegebenen kalender aufs iphone?
Oder gibts ne andere möglichkeit einen "Firmenkalender" zu erstellen und ihn dann mit dem iphone zu syncen?

lg sascha
Bitte warten ..
Mitglied: sandorfi
06.03.2011 um 18:54 Uhr
Hallo Sascha,

z.B. einen eigenen dafür Account anlegen "Firmenkalender" und diesen als zusätzliches Exchange-Konto im Phone hinzufügen. Bei den zu synchronisations-Optionen reicht dann ja nur "Kalender". Der Benutzer braucht dazu jedoch Rechte auf das Postfach.

Gruß
Simon
Bitte warten ..
Mitglied: scirocco87
16.03.2011 um 05:59 Uhr
Habe auch versucht meine Emails via Exchange auf meinem Iphone abzurufen. Habe auf den Exchange Server ein Zertifikat eingerichtet. Am Iphone kommt folgenden Fehlermeldung: "Exchange: Account Informationen konnten nicht überprüft werden.". Wenn ich aber übers Notebook im Internet Explorer die Seite https://MAIL.DOMAIN.COM/EXCHANGE eingebe kommt ein Anmeldungsfenster und kann mich dann korrekt anmelden. Kennt wer dieses Problem?
Bitte warten ..
Mitglied: Momo01
24.03.2011 um 18:19 Uhr
Hallo Andreas,

wenn auch nicht am Stück - aber auf die 3 Tage komme ich sicher auch. Deine Anleitung war meine Rettung.
Vielen Dank für die "Hausfrauen-sichere" Anleitung. Nun funktioniert es - und ich bin glücklich.

Viele Grüße!
Gabi
Bitte warten ..
Mitglied: hollow84
31.03.2011 um 10:39 Uhr
1000 Dank für die Anleitung und die Tipps

1 Frage hätte ich jedoch noch. Alles klappt mit dem sync wunderbar aber wenn ich einen neuen Kontakt auf dem Iphone anlege wird der nicht im Exchange aufgenommen. Umgekehrt funktionierts aber!

Hat jemand ne Idee?

Lg Sascha
Bitte warten ..
Mitglied: sandorfi
31.03.2011 um 11:05 Uhr
Hallo Sascha,

betrifft das Problem wirklich nur Kontakt, oder ggf auch Kalendereinträge / mails?
Sollten es nur die Kontakte sein:

-> werden die Kontakte wirklich als "Exchange-Kontakte" angelegt (oder aber IPhone / SIM / anderes Konto)

Gruß
Simon
Bitte warten ..
Mitglied: scirocco87
10.04.2011 um 15:20 Uhr
Ich kann mit dem Programm Active Sync Tester den Test erfolgreich abschließen. Mit dem Iphone funktioniert zwar das einrichten des MailAccounts aber sobald ich die Mails abrufen möchte kommt folgende Meldung:
"Emails können nicht empfangen werden. Die Verbindung mit dem Server ist fehlgeschlagen"
Am Zertifikat kann es nicht mehr liegen. Verbindungstest waren bis jetzt alle erfolgreich. Was könnte hier noch das Problem sein?

Danke
Bitte warten ..
Mitglied: Plominski
04.05.2011 um 18:29 Uhr
Sers
bei deiner Anleitung ist mir viel zu sehr am Exchange herum gefrickelt.
Das Ganze auch noch ohne SSL zu benutzen ist nicht so pralle.

Einfach:
- Windows 2003 /R2 /SBS Server aufsetzen (Datum Bug beachten)
- Exchange 2003 /SP 1-2 einrichten
Und davor ein Apache als Reverse Proxy stellen.

Nimm dir die alte Anleitung zur Hilfe: http://sbsbox.de/websites/plominski.eu/daniel/technet/Lists/Beitraege/P ...

Mit neustem Xampp, zu beachten ist nur etwas eine abgewandelte Einrichtung (SSL Zertifikaterstellung, httpd-ssl-extra-conf etc.)

Ansonsten brauchst du wirklich neben einem aktuell gepatchen Win2003/Exchange2003 überhaupt nix daran herumbasteln oder extra Tools auf dem iPhone benutzen.

Einfach Exchange Profil einrichten und gut ist, sauber vorher die Reverse URLs weiterleiten, selbst mit einem abgelaufenen IIS SSL Zertifikat läuft die ganze Schoße ordnungsgemäß

Bei mir läuft das ganze sauber auf meinen iPhones und iPad, OutlookWebAccess ebenso und auf den "nicht mehr funktionierenden" RPC over HTTP/S Relay kann ich verzichten, da ich kein Outlook mehr auf meinen Macs benutze.
Bitte warten ..
Mitglied: cordial
19.10.2011 um 11:58 Uhr
Hallo,

Bei mir ist Port 443 schon für den Terminalgatewayserver eingerichtet und über Port 80 möchte ich das nicht unbedingt machen. Welchen Lösungsvorschlag könnt ihr mir bezüglich des Ports geben?

Mit freundlichen Grüßen
Peter
Bitte warten ..
Mitglied: Globetrotter
19.10.2011 um 12:10 Uhr
Ja nu.. dann gibbets noch die Möglichkeit via VPN...

Gruss Globetrotter
Bitte warten ..
Mitglied: cordial
19.10.2011 um 12:24 Uhr
VPN möchte ich nicht, aber ich habe im IIS gesehen, dass man den SSL Port ja beliebig verändern kann. Ich könnte doch hier dann auf Port 444 ändern, am Router zum Exchange durschleifen, am Iphone SSL Port 444 angeben und dann müsste es doch funktionieren oder nicht?
Bitte warten ..
Mitglied: Globetrotter
19.10.2011 um 12:34 Uhr
Jeps, das sollte gehen...

Gruss
Bitte warten ..
Mitglied: cordial
19.10.2011 um 12:58 Uhr
Falls es wen interessiert:

Es gibt eine elegante Lösung hierfür, die schon Port 443 irgendwo anders im Einsatz haben. Am Exchange alles so lassen wie es ist und nur am Router den Portredirect (Heisst von Router zu Router anders) anpassen, d.h. man stellt die externen Port auf 444 ein und wird auf den Server mit Port 443 verwiesen (Ext. IP 444 -> 192.168.0.7:443)

Damit kann man auf dem Exchangeserver alle Porteinstellungen so lassen wie sie sind.
Bitte warten ..
Mitglied: KnuTdadude
28.11.2011 um 12:04 Uhr
Hallo rzlbrnft,

wie komme ich zu "Anmelden an"?
Bitte warten ..
Mitglied: kansiii85
16.01.2012, aktualisiert 18.10.2012
Hallo Zusammen,

ich sitze nun schon Tage an dem Problem den Exchange mit dem iPhone oder iPad zu syncen.
Habe alle Anleitungen hier Schritt für Schritt druchgeführt, doch leider keinen Erfolg.

Kann mir hierbei jemand noch einen Tipp geben?

Wäre darüber sehr dankbar:


http://www.administrator.de/forum/ipad-l%c3%a4sst-sich-nicht-an-lokalen ...
Bitte warten ..
Mitglied: Sierjoerg
17.04.2013 um 09:32 Uhr
Hallo Seardan,
die Anleitung ist ja schön und gut, nur leider hilft sie mir nicht weiter, da wir eine sichere Verbindung haben wollen. Da du aber überall SSL deaktivierst, ist die Sicherheit nicht vorhanden.
Bitte warten ..
Mitglied: Globetrotter
17.04.2013 um 12:53 Uhr
Hallo Sierjoerg,

hast Du einmal auf den Thread geschaut ? Dieser ist nämlich von 2009.
Wenn Du jedoch immer noch auf einen "alten" Hut setzen möchtest, dann kannst Du Dir eine eigene Zertifizierungsstelle installieren und somit problemlos auch über SSL kommunizieren. Denke weiterhin daran, daß W2K3 ab Ende diesen Jahres nicht mehr supportet wird und Exchange 2K3 ebenso wenig. Schlauer wäre es da einen Exchange2K10 mit W2K8R2 aufzusetzen... Ich weiß ja nicht wieviel Leute Ihr seid - evtl. wäre Smartermail dann die günstigere Variante.

Gruss Globe
Bitte warten ..
Mitglied: Sierjoerg
17.04.2013 um 13:09 Uhr
Hallo Globe,
dass mit Windows und Exchange ist mir bekannt, aber bis dato meint mein Chef wir müssten noch keinen neuen Exchangeserver anschaffen.
Ein selbst erstelltest Zertifikat habe ich, leider bekomme ich trotzdem keinen zugriff von extern via Smartphone. Oder genauer gesagt, die Emails werden auf dem Smarphone nicht angezeigt.Dass anmelden scheint zu gehen.
Ich bekomme nur die Emails auf dem Smartphone angezeigt, wenn ich den Punkt SSL vorraussetzen im IIS deaktivire.
Bitte warten ..
Mitglied: rzlbrnft
17.04.2013, aktualisiert um 13:23 Uhr
Bei vielen Smartphones ist es so das du zwingend ein Zertifikat von einer öffentlichen Zertifizierungsstelle brauchst sonst kannst du dich auf den Kopf stellen die Kommunikation wird nicht klappen. Das Zertifikat muss auf die extern erreichbare FQDN des Mailservers lauten, die muss auch im Mailconnector stehen. Port 443 an Exchange mappen für SSL dürfte ja bekannt sein. Steht aber auch schon in einigen Kommentaren weiter oben.

Wir nutzen z.B. von dieser Seite das Produkt Limitbreaker http://www.psw.net/ssl-zertifikate.cfm, ausgestellt auf mail.firmenname.de.
Darüber funktioniert die Kommunikation problemlos.

Lies dir erstmal die ganzen Antworten zum Post durch, die sind zwar teilweise für neuere Exchange Versionen haben aber auch im 2003er ihre Richtigkeit.
Bitte warten ..
Mitglied: Globetrotter
17.04.2013 um 13:56 Uhr
Hi...
a). Kläre Dein Chef auf !
b). Unter Androiden gibt es einige welche nicht so richtig mit Exchange wollen, da gibt es aber "Enhanced Email", damit gehst Du den Problemen aus der Welt ;)
c). Mach Dir mal eine Aufstellung der Smartphones welche Ihr einsetzt - da kann man nämlich recht schnell im "Schlamassel" landen. Ich selbst habe mir eine Liste erarbeitet welche ich dem Kunden hinlege und sage, dass ich diese Varianten unterstütze, für den Rest ibt es meinerseits kein Support - und das aus gutem Grund...

Gruss Globe
Bitte warten ..
Mitglied: Sierjoerg
17.04.2013 um 13:57 Uhr
Hallo rzlbrnft,
und wie läuft dass mit einer externen Statischen IP? Da hat man ja quasie keine von extern erreichbare FQDN oder?
Erfahrung mit Black Berrys (Z10) oder Androids hast du nicht rein zufällig oder? Bezogen auf die Zertifikate.
Bitte warten ..
Mitglied: Globetrotter
17.04.2013 um 13:59 Uhr
Hi rzlbrnft,
da hast Du schon "Recht", "so... bin ich billich rangekommen" ;)
Da man aber nicht weiß was für Smartphones er einsetzt, kann man leider nicht wissen ob die diversen OS-Stände auch diesem SSL-Zertifikat vertrauen ;)
Im Zweifelsfall sollte man da Stellen wie Thawte o.ä. in Betracht ziehen... und das hat eben seinen Preis...

Gruss Globe
Bitte warten ..
Mitglied: rzlbrnft
17.04.2013, aktualisiert um 14:13 Uhr
Zertifikate kann man auch auf IP-Adressen ausstellen soweit ich weiß, würde ich aber nicht empfehlen, kann immer mal vorkommen das der Provider sein Netz anders segmentieren muss und man eine neue zugeteilt bekommt.
Besser ist es beim Provider einen A-Record zu der IP auf einer Subdomain eurer Firmenhomepage zu hinterlegen, die meisten Provider bieten diese Option an. Den könnt ihr dann auch jederzeit ändern und auch als mx-record und Antwort-Adresse für den HELO Request benutzen.

Bezüglich Android oder Blackberry kann ich nichts sagen, als wir damals unseren Webzugriff eingerichtet haben, wollten nur Iphones überhaupt ohne gültiges Zertifikat mit dem Exchange sprechen, die anderen Geräte die wir so hatten haben selbst erstellte ignoriert, jedenfalls hab ich es nicht hingekriegt die Zertifikate auf dem Gerät zu importieren, war uns dann den Aufwand nicht wert verglichen mit den 39€ Gebühren für ein Jahr.
Bitte warten ..
Mitglied: Globetrotter
17.04.2013 um 14:26 Uhr
Hi rzlbrnft,
so sieht es aus ;)
bei iPhones ist das kein Problem - bis jetzt (Mal den anzen Patentkrieg abwarten)...
... ansonsten soll der die Mailkopie einfach an Google oder ähnliche Dienste weiterleiten und mit denen kommunizieren... ich würde mir bei 2003 keinen Stress mehr machen - den letzten hab ich 2011 aufgesetzt und gut is...
Alternative ist, wie ich hier schon vor Jahren gesagt abe ein VPN-Server, dann braucht man auch kein SSL ;)
Wenn nun aber kommt, dass man SIM-Karten von Congstar, Aldi oder Co. hat, dann bringt das VPN auch nicvhts weil die Ports vom Provider geblockt werden ;)

Merke: Wer billig einkauft zahlt meistens mehr ;)

Eine Planung und Analyse ist daher heute unumgänglich... zuviele OSes...

Gruss Globe
Bitte warten ..
Mitglied: Sierjoerg
19.04.2013, aktualisiert um 09:48 Uhr
Hallo an alle,
habe mein kleines Problem auf meine eigene Weise gelöst! Für den Fall, dass sich jemand für meine Lösung interessiert werde ich sie hier kurz posten.

Meine Lösung:

Im IIS habe ich die Haken für die "SSL Verbindung vorrausgesetzt" raus genommen. So mit kann ich zwar eine SSL Verbindung aufbauen, ist aber nicht zwingend notwendig.
Als nächstes habe ich im Router den Port 80 zum Mailserver gesperrt und nur noch den Port 443 für die SSL Verbindung offen gelassen. Das geht natürlich nur, wenn kein anderer Dienst auf den Port 80 auf den Mailserver lauschen muss.
In meinem Handy habe ich beim einrichten der Activesync verbindung den Haken bei " Dieser Server benötigt eine verschlüsselte Verbindung" gesetzt. Fertig!!! Somit habe ich eine Verschlüsselte Verbindung zu meinem Exchangeserver ohne Große umstellung auf dem Exchange.
Um mir auch sicher zu sein, ob die Verbindung wirklich verschlüsselt ist, habe ich den Traffic auf der Servernetzwerkkarte mit Wireshark aufgezeichnet und zwar einmal mit SSL und einmal ohne SSL.
Ohne SSL konnte ich alles klar und deutlich lesen, Benutzername, Passwort, sogar von welchem Gerät die Anfrage kam. Mit ssl war dies nicht mehr möglich. Ich konnte nur noch erkennen, dass ein Gerät von extern eine SSL Anfrage (Client Hallo) an den Server gerichtet hat, und dieser mit einem (Server Hallo) geantwortet hat.

So ich hoffe euch gefällt meine kleine Lösung zu diesem Problem.
Bitte warten ..
Mitglied: Globetrotter
19.04.2013 um 10:01 Uhr
Moin...
zielich lustich, Deine ABM ;)
Finde es nur komisch warum es vorher nicht funktioniert hat, an den Zertifikaten hast Du ja nichts geändert, am Router nur den 80er dicht gemacht und der Exchange staet wie vorher da....
Naja...

Gruss Globe
Bitte warten ..
Mitglied: Sierjoerg
19.04.2013 um 10:11 Uhr
Nein tut er nicht! Ich habe die Haken bei "SSL verschlüsselung vorrausgesetzt" rausgenommen. Vorher waren sie immer drin.
Damit ging es dann nicht. Eine mögliche Erklärung dazu habe ich, so glaube ich zumindest, auf dieser Seite gefunden.

http://support.microsoft.com/kb/817379/en-us

Da wird beschrieben, das es mit Activesync und OMA nicht möglich ist auf die Exchange Seite zuzugreifen, wenn SSL aktiviert ist.
Deren Lösung dazu habe ich aber abgelehnt, da ich dafür zuviel am Server ändern müsste.
Bitte warten ..
Mitglied: Globetrotter
19.04.2013 um 10:31 Uhr
Nicht aufregen!, ist bald Wochenende...
Ist doch i.O. wenn es funktioniert und Dein Chefe sowie Du damit zufrieden sind.

Nice WE,

Gruss Globe
Bitte warten ..
Mitglied: Sierjoerg
19.04.2013 um 11:13 Uhr
Aufgeregt habe ich mich eigentlich nicht! Nur ein bischen falsch ausgedrückt.

Ich wünsche auch noch ein schönes WE und danke noch mal für die ganzen Antworten und Hilfestellungen.

Ach ja Wochenende...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Apple
IPhone 6 im WLAN kein Zugriff auf Exchange Server (8)

Frage von montana zum Thema Apple ...

Exchange Server
Exchange 2010 Active-Sync-Zugriff auf Exchange 2016 Postfach (1)

Frage von diemilz zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2013 Öffentliche Ordner über Active Sync werden nicht angezeigt (5)

Frage von Xartor zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...