Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mehrere IP-Adress-Segmente für verschiedene Gruppen

Frage Netzwerke

Mitglied: djbazo

djbazo (Level 1) - Jetzt verbinden

10.06.2009, aktualisiert 18.10.2012, 5035 Aufrufe, 7 Kommentare

Ich möchte verschiedene Arbeitsgruppen per IP-Segment trennen.

Ein DSL-Router (Telekom), mehrere Clients (sagen wir mal 3) - kein Server.

Annahme:
DSL-Router IP: 192.168.0.1
Client 1 soll die IP 192.168.0.x bekommen
Client 2 soll die IP 192.168.2.x bekommen
Client 3 soll die IP 192.168.3.x bekommen


Alle sollen ins Internet über den Router kommen - sich aber selbst nicht sehen.
Was muss hierfür speziell am Router bzw Client eingestellt werden?


Vielen Dank vorab.

Grüße
bazo
Mitglied: education
10.06.2009 um 13:23 Uhr
deine antwort wäre V-Lans. wirst aber nicht mit den billig-Router schaffen.

andere möglichkeit:


4 router.


DSL-Router: 192.168.0.1 ->> internet.


3 router für die netzwerke: 192.168.1.x, 192.168.2.x. 192.168.3.x

diese 3 router mit den wan an dslrouter 192.168.0.1
Bitte warten ..
Mitglied: RoterFruchtZwerg
10.06.2009 um 14:33 Uhr
Router bekommt:
192.168.0.0/24

Deine Clients bekommen darin /30er Netze... Die erste IP in dem /30 Netz setzt du als Gateway fest, die zweite bekommt dein jeweiliger Client.
Für die Gateway-IP hinterlegst du im ARP-Cache der Clients die MAC Adresse des Routers.
Da der Router nie über seine IP-Adresse angesprochen wird, ist es egal, dass der Client nicht die echte IP Adresse des Routers kennt, bzw. diese ausserhalb des Subnetzes des Clients liegt.

Also, Client1:
IP: 192.168.0.6/30
GW: 192.168.0.5
Static ARP-Eintrag für 192.168.0.5 auf MAC des Routers

Also, Client2:
IP: 192.168.0.10/30
GW: 192.168.0.9
Static ARP-Eintrag für 192.168.0.9 auf MAC des Routers

usw...

die Clients sind damit alle voneinander getrennt - für den Router sind aber noch alle im selben Subnetz.

Ich hab mir das gerade einfach ausgedacht, kann sein dass ich einen bösen Denkfehler drin habe - aber wenn nicht, dürfte das funktionieren.


Edit: Ahhh... da kommt schon ein Denkfehler... Der Router frägt natürlich "WHO HAS 192.168.0.6? TELL 192.168.0.1"... Ist dann die Frage, wie die Clients soeinen Fall behandeln...
Bitte warten ..
Mitglied: aqui
10.06.2009, aktualisiert 18.10.2012
Das ist alles Frickelei und ausserdem nicht supportet unter TCP/IP und wenns dennoch klappt ein Zufall.

Generell kann sowas nicht funktionieren was du da machst, da alle deine Clients in unterschiedlichen IP Netzen sind und einen Router benötigen der sie wieder auf einen Internet Anschluss zusammenführt !
Mit einem billigen Consumer Router ist das nicht zu machen !

Wenn es dir darum geht das nur die Clients am Switch sich nicht untereinander sehen können, dann besorg dir einen billigen Switch der sog. Private VLANs supportet !!
Damit ist ein ARP Traffic untereinander unterbunden und die Clients können so in einem PVLAN nicht miteinander kommunizieren in einem Netzwerk, außer mit dem Router der an einem definierten Uplink Port dieses Switches angeschlossen ist.

Mittlerweile haben auch Billigswitches solche PVLAN Funktion.

Andere Möglichkeit:
Du besorgst dir einen billigen VLAN fähigen Switch und einen VLAN fähigen DSL Router und koppelst das.

Wie das mit einer kostenfreien Lösung funktioniert sagt dir dieses Tutorial:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

So wird ein Schuh draus....!
Bitte warten ..
Mitglied: St-Andreas
10.06.2009 um 16:43 Uhr
Musst Du nix für einstellen, weil geht einfach nicht!
Aqui hat schon genügend Hinweise gegeben.

Aber wenn Du verrätst warum du das machen willst können wir Dir vielleicht noch andere Tips geben?
Bitte warten ..
Mitglied: dog
11.06.2009 um 21:15 Uhr
Auch wenn ich prinzipiell der Meinung bin, dass sowas nicht geht.
Im Prinzip ist es ja genau das, was die Telekom bei jedem normalen DSL-Anschluss macht.
Die Routing-Tabelle sieht dann so aus:

Ziel Maske Gateway iface
192.168.0.1 255.255.255.255 0.0.0.0 WAN
0.0.0.0 0.0.0.0 192.168.0.1 WAN

(Die IP des Clients selbst an WAN sei z.b. 192.168.4.5 mit Maske 255.255.255.255)

Kann mir das jemand erklären?

Grüße

Max
Bitte warten ..
Mitglied: chfr77
12.06.2009 um 17:46 Uhr
Zitat von dog:
Kann mir das jemand erklären?
Max

Ich hoffe nicht :D
Bitte warten ..
Mitglied: aqui
13.06.2009 um 10:44 Uhr
@djbazo
Wenns das jetzt gewesen ist bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!!
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(6)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Linux
gelöst Google Chrome startet nicht (12)

Frage von Thomas91 zum Thema Linux ...